4d81d052963d4b4bd387f9cdc04d68fdfc064ae3
[gentoo.git] / dev-python / towncrier / towncrier-19.2.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7} )
7 inherit distutils-r1
8
9 DESCRIPTION="Building newsfiles for your project"
10 HOMEPAGE="https://github.com/hawkowl/towncrier"
11 SRC_URI="https://github.com/hawkowl/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~alpha amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
16 IUSE="test"
17
18 RDEPEND="
19         dev-python/click[${PYTHON_USEDEP}]
20         dev-python/click-default-group[${PYTHON_USEDEP}]
21         dev-python/jinja[${PYTHON_USEDEP}]
22         dev-python/incremental[${PYTHON_USEDEP}]
23         dev-python/toml[${PYTHON_USEDEP}]
24 "
25 BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
26         test? (
27                 dev-vcs/git
28                 >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
29         )"
30
31 RESTRICT="!test? ( test )"
32
33 python_test() {
34         distutils_install_for_testing
35
36         trial towncrier || die "tests failed with ${EPYTHON}"
37 }