*/*: [QA] Fix trivial cases of MissingTestRestrict
[gentoo.git] / dev-python / tinycss2 / tinycss2-1.0.2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{5,6} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="A complete yet simple CSS parser for Python"
11 HOMEPAGE="https://github.com/Kozea/tinycss2/ https://pypi.python.org/pypi/tinycss2/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND=">=dev-python/webencodings-0.4[${PYTHON_USEDEP}]"
21 DEPEND="${RDEPEND}
22         >=dev-python/setuptools-39.2.0[${PYTHON_USEDEP}]
23         test? (
24                 dev-python/pytest-cov[${PYTHON_USEDEP}]
25                 dev-python/pytest-flake8[${PYTHON_USEDEP}]
26                 dev-python/pytest-isort[${PYTHON_USEDEP}]
27                 dev-python/pytest-runner[${PYTHON_USEDEP}]
28                 dev-python/pytest[${PYTHON_USEDEP}]
29         )
30 "
31
32 DOCS=( README.rst )
33
34 python_test() {
35         py.test || die "testsuite failed under ${EPYTHON}"
36 }