*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / thunarx-python / thunarx-python-0.5.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python{2_7,3_6} )
6
7 inherit python-single-r1
8
9 DESCRIPTION="Python bindings for the Thunar file manager"
10 HOMEPAGE="https://goodies.xfce.org/projects/bindings/thunarx-python"
11 SRC_URI="https://archive.xfce.org/src/bindings/${PN}/${PV%.*}/${P}.tar.bz2"
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="amd64 x86"
16 IUSE=""
17
18 RDEPEND="${PYTHON_DEPS}
19         >=x11-libs/gtk+-3.20:3
20         >=dev-libs/glib-2.30:2
21         >=dev-python/pygobject-3.20:3[${PYTHON_USEDEP}]
22         >=xfce-base/thunar-1.7.0"
23 DEPEND="${RDEPEND}
24         virtual/pkgconfig"
25 REQUIRED_USE=${PYTHON_REQUIRED_USE}
26
27 src_install() {
28         default
29
30         find "${D}" -name '*.la' -delete || die
31 }