*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / textx / textx-1.4.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python3_6 )
7
8 inherit distutils-r1
9
10 MY_PN=textX
11 MY_P=${MY_PN}-${PV}
12 DESCRIPTION="Meta-language for DSL implementation inspired by Xtext"
13 HOMEPAGE="https://pypi.org/project/textX/ https://github.com/igordejanovic/textX"
14 SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
15 # pypi tarball omits tests
16 RESTRICT="test"
17 LICENSE="MIT"
18 SLOT="0"
19 KEYWORDS="~amd64 ~x86"
20 IUSE="test"
21
22 RDEPEND="dev-python/arpeggio[${PYTHON_USEDEP}]"
23 DEPEND="${RDEPEND}
24         dev-python/setuptools[${PYTHON_USEDEP}]
25         test? (
26                 dev-python/pytest[${PYTHON_USEDEP}]
27         )
28 "
29 S=${WORKDIR}/${MY_P}
30
31 python_test() {
32         py.test -v tests/functional || die "tests failed"
33 }