*/*: Discontinue Gentoo SuperH port
[gentoo.git] / dev-python / testresources / testresources-1.0.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="A pyunit extension for managing expensive test resources"
11 HOMEPAGE="https://launchpad.net/testresources"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="Apache-2.0"
15 SLOT="0"
16 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 DEPEND="
21         dev-python/setuptools[${PYTHON_USEDEP}]
22         test? (
23                 dev-python/nose[${PYTHON_USEDEP}]
24                 dev-python/testtools[${PYTHON_USEDEP}]
25                 dev-python/fixtures[${PYTHON_USEDEP}]
26         )"
27 RDEPEND=""
28
29 python_prepare_all() {
30         sed \
31                 -e 's:testBasicSortTests:_&:g' \
32                 -i testresources/tests/test_optimising_test_suite.py || die
33         distutils-r1_python_prepare_all
34 }
35
36 python_test() {
37         nosetests --verbose || die "Tests failed under ${EPYTHON}"
38 }