*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / testpath / testpath-0.4.4.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7,8}} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Test utilities for code working with files and commands"
11 HOMEPAGE="https://github.com/jupyter/testpath https://testpath.readthedocs.io/en/latest/"
12 SRC_URI="https://github.com/jupyter/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
17 IUSE="test"
18
19 DEPEND="
20         test? (
21                 dev-python/pathlib2[${PYTHON_USEDEP}]
22                 dev-python/pytest[${PYTHON_USEDEP}]
23         )
24 "
25
26 PATCHES=(
27         "${FILESDIR}/${PN}-0.2-setup.py.patch"
28 )
29
30 distutils_enable_tests pytest
31 distutils_enable_sphinx doc
32
33 python_prepare_all() {
34         # Prevent un-needed download during build
35         sed -e "/^    'sphinx.ext.intersphinx',/d" -i doc/conf.py || die
36
37         distutils-r1_python_prepare_all
38 }