*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / tabulate / tabulate-0.8.3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Pretty-print tabular data"
11 HOMEPAGE="https://pypi.org/project/tabulate/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 SLOT="0"
15 LICENSE="MIT"
16 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND="
21         dev-python/wcwidth[${PYTHON_USEDEP}]"
22 # TODO: optional test-dep on colorclass
23 DEPEND="
24         test? (
25                 ${RDEPEND}
26                 $(python_gen_impl_dep 'sqlite')
27                 dev-python/colorclass[${PYTHON_USEDEP}]
28                 dev-python/nose[${PYTHON_USEDEP}]
29                 dev-python/numpy[${PYTHON_USEDEP}]
30                 dev-python/pandas[${PYTHON_USEDEP}]
31                 virtual/python-funcsigs[${PYTHON_USEDEP}]
32         )
33 "
34
35 python_test() {
36         esetup.py test
37 }