*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / tabulate / tabulate-0.8.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_6 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Pretty-print tabular data"
11 HOMEPAGE="https://pypi.org/project/tabulate/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 SLOT="0"
15 LICENSE="MIT"
16 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
17 IUSE="test"
18
19 RDEPEND=""
20 DEPEND="${RDEPEND}
21         test? ( virtual/python-funcsigs[${PYTHON_USEDEP}] )
22 "
23
24 # Missing something in tarball
25 #
26 # from common import assert_equal
27 RESTRICT=test
28
29 python_test() {
30         local testcase
31         for testcase in test/*py; do
32                 ${PYTHON} ${testcase} || die
33         done
34 }