*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / strict-rfc3339 / strict-rfc3339-0.6.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Strict, simple, lightweight RFC3339 functions"
11 HOMEPAGE="https://pypi.org/project/strict-rfc3339/ https://github.com/danielrichman/strict-rfc3339"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 SLOT="0"
15 LICENSE="GPL-3+"
16 KEYWORDS="alpha amd64 ~arm arm64 ~hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux"
17 IUSE=""
18
19 # Not shipped
20 RESTRICT=test
21
22 python_test() {
23         ${PYTHON} test_strict_rfc3339.py || die
24 }