*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / statsd / statsd-3.2.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_6} pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="A simple statsd client"
11 HOMEPAGE="https://github.com/jsocol/pystatsd
12         https://pypi.org/project/statsd/"
13 SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
14
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
18 IUSE="test"
19 RESTRICT="!test? ( test )"
20
21 RDEPEND=""
22 DEPEND="${RDEPEND}
23         dev-python/setuptools[${PYTHON_USEDEP}]
24         test? (
25                 dev-python/nose[${PYTHON_USEDEP}]
26         )"
27
28 python_test() {
29         nosetests --verbose || die
30 }