*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / sphinxcontrib-httpdomain / sphinxcontrib-httpdomain-1.4.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 PYTHON_COMPAT=( python{2_7,3_6} )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Extension providing a Sphinx domain for describing RESTful HTTP APIs"
10 HOMEPAGE="https://bitbucket.org/birkenfeld/sphinx-contrib/
11         https://sphinxcontrib-httpdomain.readthedocs.io/en/stable/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="BSD-2"
15 SLOT="0"
16 KEYWORDS="amd64 x86"
17
18 RDEPEND=">=dev-python/sphinx-1.0[${PYTHON_USEDEP}]
19         dev-python/six[${PYTHON_USEDEP}]"
20 DEPEND="${RDEPEND}
21         dev-python/setuptools[${PYTHON_USEDEP}]"