*/*: Discontinue Gentoo SuperH port
[gentoo.git] / dev-python / sphinxcontrib-htmlhelp / sphinxcontrib-htmlhelp-1.0.3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Sphinx extension which outputs HTML help book"
10 HOMEPAGE="https://www.sphinx-doc.org
11         https://github.com/sphinx-doc/sphinxcontrib-htmlhelp"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="BSD-2"
15 SLOT="0"
16 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
17
18 RDEPEND="dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
19 PDEPEND="
20         >=dev-python/sphinx-2.0[${PYTHON_USEDEP}]"
21 DEPEND="
22         dev-python/setuptools[${PYTHON_USEDEP}]
23         test? ( ${PDEPEND} )"
24
25 distutils_enable_tests pytest
26
27 python_install_all() {
28         distutils-r1_python_install_all
29         find "${ED}" -name '*.pth' -delete || die
30 }