*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / sphinxcontrib-htmlhelp / sphinxcontrib-htmlhelp-1.0.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Sphinx extension which outputs HTML help book"
10 HOMEPAGE="http://www.sphinx-doc.org"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="BSD-2"
14 SLOT="0"
15
16 KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
17
18 RDEPEND=""
19 PDEPEND="
20         >=dev-python/sphinx-2.0[${PYTHON_USEDEP}]"
21 DEPEND="
22         dev-python/setuptools[${PYTHON_USEDEP}]"
23
24 python_install_all() {
25         distutils-r1_python_install_all
26         find "${ED}" -name '*.pth' -delete || die
27 }