*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / sphinxcontrib-documentedlist / sphinxcontrib-documentedlist-0.6.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python3_6 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Sphinx extension to convert a Python list into a generated table"
11 HOMEPAGE="https://github.com/chintal/sphinxcontrib-documentedlist"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="amd64 arm64 ~x86"
17 IUSE=""
18
19 RDEPEND="
20         dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
21         dev-python/sphinx[${PYTHON_USEDEP}]
22 "
23 DEPEND="
24         dev-python/setuptools[${PYTHON_USEDEP}]
25         dev-python/six[${PYTHON_USEDEP}]
26 "
27
28 python_install_all() {
29         distutils-r1_python_install_all
30         find "${ED}" -name '*.pth' -delete || die
31 }