*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / sphinxcontrib-blockdiag / sphinxcontrib-blockdiag-1.5.5.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python2_7 python3_6 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="A sphinx extension for embedding block diagrams using blockdiag"
10
11 HOMEPAGE="https://github.com/blockdiag/sphinxcontrib-blockdiag"
12
13 SRC_URI="https://github.com/blockdiag/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
14
15 LICENSE="BSD"
16
17 SLOT="0"
18
19 KEYWORDS="~amd64"
20
21 IUSE=""
22
23 DEPEND="
24         dev-python/sphinx[${PYTHON_USEDEP}]
25         >=dev-python/blockdiag-1.5.0[${PYTHON_USEDEP}]
26 "
27
28 RDEPEND="${DEPEND}"
29
30 python_prepare_all() {
31         sed -i -e /build-base/d setup.cfg || die
32         distutils-r1_python_prepare_all
33 }