*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / sphinxcontrib-blockdiag / sphinxcontrib-blockdiag-1.5.5-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python2_7 python3_6 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="A sphinx extension for embedding block diagrams using blockdiag"
10 HOMEPAGE="https://github.com/blockdiag/sphinxcontrib-blockdiag"
11 SRC_URI="https://github.com/blockdiag/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
16 IUSE=""
17
18 COMMON_DEPEND="
19         dev-python/sphinx[${PYTHON_USEDEP}]
20         >=dev-python/blockdiag-1.5.0[${PYTHON_USEDEP}]
21 "
22 DEPEND="
23         dev-python/setuptools[${PYTHON_USEDEP}]"
24 RDEPEND="${DEPEND}
25         dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
26
27 python_prepare_all() {
28         sed -i -e /build-base/d setup.cfg || die
29         distutils-r1_python_prepare_all
30 }
31
32 python_install_all() {
33         distutils-r1_python_install_all
34         find "${ED}" -name '*.pth' -delete || die
35 }