*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / sphinxcontrib-asyncio / sphinxcontrib-asyncio-0.2.0-r2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
7 inherit distutils-r1
8
9 DESCRIPTION="sphinx extension to support coroutines in markup"
10 HOMEPAGE="https://github.com/aio-libs/sphinxcontrib-asyncio"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="amd64 ~arm ~arm64 x86 ~amd64-linux ~x86-linux"
16 IUSE="doc"
17
18 DEPEND="
19         dev-python/setuptools[${PYTHON_USEDEP}]
20         doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
21 "
22 RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]
23         dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
24
25 python_compile_all() {
26         use doc && emake -C docs html
27 }
28
29 python_install() {
30         rm "${BUILD_DIR}"/lib/sphinxcontrib/__init__.py || die
31         distutils-r1_python_install --skip-build
32 }
33
34 python_install_all() {
35         use doc && local HTML_DOCS=( docs/_build/html/. )
36         distutils-r1_python_install_all
37         # clean up pth files bug #623852
38         find "${ED}" -name '*.pth' -delete || die
39 }