*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / sphinx-issues / sphinx-issues-1.2.0.ebuild
1 # Copyright 2019-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7})
7 inherit distutils-r1
8
9 DESCRIPTION="A Sphinx extension for linking to your project's issue tracker "
10 HOMEPAGE="https://github.com/sloria/sphinx-issues"
11 SRC_URI="https://github.com/sloria/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
16
17 RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
18 BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
19
20 distutils_enable_tests pytest