*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / sphinx-gallery / sphinx-gallery-0.3.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Sphinx extension to automatically generate an examples gallery"
11 HOMEPAGE="http://sphinx-gallery.readthedocs.io/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
17 IUSE=""
18
19 RDEPEND="
20         dev-python/matplotlib[${PYTHON_USEDEP}]
21         dev-python/pillow[${PYTHON_USEDEP}]
22         dev-python/sphinx[${PYTHON_USEDEP}]
23 "
24 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
25
26 # tests need extra files not distributed