*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / sortedcollections / sortedcollections-0.5.3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python2_7 python3_{6,7} )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Python library to sort collections and containers"
10 HOMEPAGE="http://www.grantjenks.com/docs/sortedcontainers/"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
16 IUSE="test"
17 RESTRICT="!test? ( test )"
18
19 RDEPEND="dev-python/sortedcontainers[${PYTHON_USEDEP}]"
20 DEPEND="${RDEPEND}
21         test? ( dev-python/pytest[${PYTHON_USEDEP}] )"