*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / slixmpp / slixmpp-1.4.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python3_6 )
6
7 inherit eutils distutils-r1
8
9 DESCRIPTION="Python 3 library for XMPP"
10 HOMEPAGE="https://dev.louiz.org/projects/slixmpp"
11 LICENSE="MIT"
12 SLOT="0"
13 IUSE="test"
14 RESTRICT="!test? ( test )"
15
16 if [[ "${PV}" == "9999" ]]; then
17         EGIT_REPO_URI="https://lab.louiz.org/poezio/${PN}.git"
18         inherit git-r3
19 else
20         SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
21         KEYWORDS="~amd64"
22 fi
23
24 RDEPEND="
25         dev-python/aiodns[${PYTHON_USEDEP}]
26         dev-python/pyasn1-modules[${PYTHON_USEDEP}]
27         dev-python/pyasn1[${PYTHON_USEDEP}]
28 "
29 DEPEND="
30         dev-python/setuptools[${PYTHON_USEDEP}]
31         net-dns/libidn
32         test? ( $RDEPEND )
33 "
34
35 python_test() {
36         esetup.py test
37 }