*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / sleekxmpp / sleekxmpp-1.3.1-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python{2_7,3_6} )
6
7 inherit eutils distutils-r1
8
9 MY_PN=SleekXMPP
10 MY_P=${MY_PN}-${PV}
11
12 DESCRIPTION="Python library for XMPP"
13 HOMEPAGE="http://sleekxmpp.com/ https://github.com/fritzy/SleekXMPP/"
14 SRC_URI="https://github.com/fritzy/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
15
16 LICENSE="MIT"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86"
19 IUSE="crypt"
20
21 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
22 RDEPEND="crypt? ( dev-python/python-gnupg[${PYTHON_USEDEP}] )"
23
24 S=${WORKDIR}/${MY_P}
25
26 python_test() {
27         esetup.py test
28 }