*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / simplesoapy / simplesoapy-1.5.1-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7} )
7 inherit distutils-r1
8
9 DESCRIPTION="Simple pythonic wrapper for SoapySDR library"
10 HOMEPAGE="https://github.com/xmikos/simplesoapy"
11
12 LICENSE="MIT"
13 SLOT="0"
14
15 if [ "${PV}" = "9999" ]; then
16         KEYWORDS=""
17         inherit git-r3
18         EGIT_REPO_URI="https://github.com/xmikos/simplesoapy.git"
19 else
20         KEYWORDS="~amd64 ~x86"
21         SRC_URI="https://github.com/xmikos/simplesoapy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
22 fi
23
24 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
25 RDEPEND="${DEPEND}
26         dev-python/numpy[${PYTHON_USEDEP}]
27         net-wireless/soapysdr[python]
28         net-wireless/soapysdr[${PYTHON_USEDEP}]"