*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / simples3 / simples3-1.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5 PYTHON_COMPAT=( python2_7 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="A fairly simple, decently quick python interface to Amazon's S3 storage service"
10 HOMEPAGE="http://sendapatch.se/projects/simples3/ https://pypi.org/project/simples3/"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="test"
17 RESTRICT="!test? ( test )"
18
19 DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
20
21 DOCS=( changes.rst README TODO )
22
23 python_prepare_all() {
24         sed -i -e "s/setuptools/distutils.core/" setup.py || die
25
26         distutils-r1_python_prepare_all
27 }
28
29 python_test() {
30         nosetests || die "Tests fail with ${EPYTHON}"
31 }