*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / sexpdata / sexpdata-0.0.3-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=(python{2_7,3_6})
7
8 inherit distutils-r1
9
10 DESCRIPTION="a simple S-expression parser/serializer"
11 HOMEPAGE="https://github.com/tkf/sexpdata"
12 SRC_URI="https://github.com/tkf/sexpdata/archive/v${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="BSD-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
21
22 python_test() {
23         nosetests || die
24 }