f4ca5e5ac70ce13e1d6ad0fcf5c1fa328502d553
[gentoo.git] / dev-python / service_identity / service_identity-18.1.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Service identity verification for pyOpenSSL"
11 HOMEPAGE="https://github.com/pyca/service-identity"
12 SRC_URI="https://github.com/pyca/service-identity/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
13 S=${WORKDIR}/${P/_/-}
14
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 m68k ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
18
19 # TODO: upstream made pyopenssl optional
20 RDEPEND="
21         dev-python/pyasn1[${PYTHON_USEDEP}]
22         dev-python/pyasn1-modules[${PYTHON_USEDEP}]
23         >=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}]
24         dev-python/attrs[${PYTHON_USEDEP}]"
25 BDEPEND="
26         dev-python/setuptools[${PYTHON_USEDEP}]"
27
28 distutils_enable_sphinx docs
29 distutils_enable_tests pytest