*/*: [QA] Fix trivial cases of MissingTestRestrict
[gentoo.git] / dev-python / serverfiles / serverfiles-0.2.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{5,6})
7 inherit distutils-r1
8
9 DESCRIPTION="Utility for accessing HTTP server and storing files locally for reuse"
10 HOMEPAGE="https://github.com/biolab/serverfiles"
11 SRC_URI="https://github.com/biolab/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="GPL-3+"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="test"
17 RESTRICT="!test? ( test )"
18
19 RDEPEND=">=dev-python/requests-2.11.1[${PYTHON_USEDEP}]"
20 DEPEND="${DEPEND}
21         dev-python/setuptools[${PYTHON_USEDEP}]
22         dev-python/setuptools_scm[${PYTHON_USEDEP}]
23         test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
24
25 python_test(){
26         py.test -v || die "Tests fail with ${EPYTHON}"
27 }