*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / serpent / serpent-1.19.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python2_7 python3_{6,7} )
6
7 inherit distutils-r1
8
9 DESCRIPTION="A simple serialization library based on ast.literal_eval"
10 HOMEPAGE="https://pypi.org/project/serpent/ https://github.com/irmen/Serpent"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="amd64 ~arm64 ppc ppc64 x86"
16 IUSE=""
17
18 # not bundled
19 RESTRICT="test"
20
21 python_test() {
22         pushd "${S}"/tests >/dev/null || die
23         ${PYTHON} -bb test_serpent.py || die
24         popd >/dev/null || die
25 }