*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / send2trash / send2trash-1.5.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python{2_7,3_{6,7}} )
7
8 inherit distutils-r1
9
10 MY_PN="Send2Trash"
11 MY_P="${MY_PN}-${PV}"
12
13 DESCRIPTION="Sends files to the Trash (or Recycle Bin)"
14 HOMEPAGE="
15         https://pypi.org/project/Send2Trash/
16         https://github.com/hsoft/send2trash"
17 SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
18
19 SLOT="0"
20 LICENSE="BSD"
21 KEYWORDS="amd64 x86"
22 IUSE=""
23
24 RDEPEND=""
25 DEPEND="${RDEPEND}
26         dev-python/setuptools[${PYTHON_USEDEP}]"
27
28 S="${WORKDIR}"/${MY_P}
29
30 PATCHES=(
31         "${FILESDIR}/${P}-fix-broken-tests-on-py2.patch"
32 )
33
34 python_test() {
35         ${EPYTHON} setup.py test
36 }