*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / schema / schema-0.6.6.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python3_6 pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Library for validating Python data structures"
11 HOMEPAGE="https://pypi.org/project/schema/ https://github.com/keleshev/schema"
12 SRC_URI="
13         mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
14         https://github.com/keleshev/schema/archive/v${PV}.zip -> ${P}.tar.gz
15 "
16
17 SLOT="0"
18 LICENSE="MIT"
19 KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
20
21 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"