*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / scandir / scandir-1.10.0-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="A better directory iterator and faster os.walk()"
11 HOMEPAGE="https://github.com/benhoyt/scandir"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
21
22 python_test() {
23         ${EPYTHON} test/run_tests.py -v || die "tests failed under ${EPYTHON}"
24 }