*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / s3fs / s3fs-0.1.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_6} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Pythonic file interface to S3"
11 HOMEPAGE="https://s3fs.readthedocs.io/en/latest/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND="dev-python/boto3[${PYTHON_USEDEP}]"
21 DEPEND="${RDEPEND}
22         dev-python/setuptools[${PYTHON_USEDEP}]
23         test? (
24            dev-python/moto[${PYTHON_USEDEP}]
25            dev-python/pytest[${PYTHON_USEDEP}]
26         )
27 "
28
29 python_test() {
30         py.test -v || die
31 }