*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / rosdistro / rosdistro-0.8.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python{2_7,3_6,3_7} pypy3 )
6
7 SCM=""
8 if [ "${PV#9999}" != "${PV}" ] ; then
9         SCM="git-r3"
10         EGIT_REPO_URI="https://github.com/ros-infrastructure/rosdistro"
11 fi
12
13 inherit ${SCM} distutils-r1
14
15 DESCRIPTION="Tools to work with catkinized rosdistro files"
16 HOMEPAGE="http://wiki.ros.org/rosdistro"
17 if [ "${PV#9999}" != "${PV}" ] ; then
18         SRC_URI=""
19         KEYWORDS=""
20 else
21         SRC_URI="https://github.com/ros-infrastructure/rosdistro/archive/${PV}.tar.gz -> ${P}.tar.gz"
22         KEYWORDS="~amd64 ~arm"
23 fi
24
25 LICENSE="BSD"
26 SLOT="0"
27 IUSE="test"
28 RESTRICT="!test? ( test )"
29
30 RDEPEND="
31         dev-python/catkin_pkg[${PYTHON_USEDEP}]
32         dev-python/rospkg[${PYTHON_USEDEP}]
33         dev-python/pyyaml[${PYTHON_USEDEP}]
34         dev-python/setuptools[${PYTHON_USEDEP}]"
35 BDEPEND="
36         dev-python/setuptools[${PYTHON_USEDEP}]
37         test? ( dev-python/nose[${PYTHON_USEDEP}] )
38 "
39 DEPEND="${RDEPEND}
40         test? (
41                 dev-python/mock[${PYTHON_USEDEP}]
42         )
43 "
44 PATCHES=( "${FILESDIR}/yaml.patch" )
45
46 src_prepare() {
47         # Requires network access
48         rm -f test/test_manifest_providers.py
49         default
50 }
51
52 python_test() {
53         nosetests --with-xunit test || die
54 }