*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / roman / roman-2.0.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python{2_7,3_6} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="An Integer to Roman numerals converter"
11 HOMEPAGE="https://pypi.org/project/roman/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
13
14 LICENSE="PSF-2"
15 SLOT="0"
16 KEYWORDS="amd64 x86"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND="!<dev-python/docutils-0.9[${PYTHON_USEDEP}]"
21 DEPEND="${RDEPEND}
22         dev-python/setuptools[${PYTHON_USEDEP}]
23         app-arch/unzip"
24
25 python_test() {
26         cp "${S}/src/tests.py" . || die "copying test file failed"
27         esetup.py test
28 }