*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / rnc2rng / rnc2rng-2.6.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python2_7 python3_{6,7} )
6
7 inherit distutils-r1
8
9 DESCRIPTION="RELAX NG Compact to regular syntax conversion library"
10 HOMEPAGE="https://github.com/djc/rnc2rng"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="public-domain"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="test"
17
18 DEPEND="dev-python/rply[${PYTHON_USEDEP}]"
19 RDEPEND="${DEPEND}"
20
21 RESTRICT="!test? ( test )"
22
23 python_test() {
24         "${PYTHON}" test.py
25 }