*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / rfc3987 / rfc3987-1.3.7.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Parsing and validation of URIs (RFC 3986) and IRIs (RFC 3987)"
11 HOMEPAGE="https://github.com/dgerber/rfc3987 https://pypi.org/project/rfc3987/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux"
17 IUSE=""
18
19 RDEPEND="$(python_gen_cond_dep \
20         'dev-python/regex[${PYTHON_USEDEP}]' python2_7 'python3*' pypy)"
21 DEPEND="${RDEPEND}
22         dev-python/setuptools[${PYTHON_USEDEP}]
23 "
24
25 python_test() {
26         ${EPYTHON} -m doctest -v "${S}/${PN}.py" || die
27 }