*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / rfc3986 / rfc3986-1.2.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3)
6
7 inherit distutils-r1
8
9 DESCRIPTION="Validating URI References per RFC 3986"
10 HOMEPAGE="https://tools.ietf.org/html/rfc3986
11         https://github.com/sigmavirus24/rfc3986
12         https://rfc3986.rtfd.org"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
14
15 LICENSE="Apache-2.0"
16 SLOT="0"
17 KEYWORDS="alpha amd64 ~arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
18 IUSE="test"
19 RESTRICT="!test? ( test )"
20
21 DEPEND="
22         dev-python/setuptools[${PYTHON_USEDEP}]
23         test? ( dev-python/pytest[${PYTHON_USEDEP}] )
24 "
25 RDEPEND=""
26
27 python_test() {
28         py.test -vv || die
29 }