*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / restructuredtext-lint / restructuredtext-lint-1.1.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python{2_7,3_{6,7}} )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Checks PyPI validity of reStructuredText"
10 HOMEPAGE="https://pypi.org/project/restructuredtext_lint/"
11
12 MY_P="restructuredtext_lint"
13 SRC_URI="mirror://pypi/${PN:0:1}/${MY_P}/${MY_P}-${PV}.tar.gz"
14 S="${WORKDIR}/${MY_P}-${PV}"
15
16 LICENSE="Unlicense"
17 SLOT="0"
18 KEYWORDS="~amd64 ~arm64 ~x86"
19 IUSE="test"
20 RESTRICT="!test? ( test )"
21
22 DEPEND="
23         dev-python/setuptools[${PYTHON_USEDEP}]
24         test? (
25                 dev-python/nose[${PYTHON_USEDEP}]
26                 dev-python/pyyaml[${PYTHON_USEDEP}]
27         )
28 "
29 RDEPEND="
30         >=dev-python/docutils-0.11[${PYTHON_USEDEP}]
31         <dev-python/docutils-1.0[${PYTHON_USEDEP}]"
32
33 python_test() {
34          nosetests -v || die
35 }