*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / responses / responses-0.9.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python{2_7,3_{6,7}} )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Utility for mocking out the Python Requests library"
10 HOMEPAGE="https://github.com/getsentry/responses"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
16 IUSE="test"
17 RESTRICT="!test? ( test )"
18
19 RDEPEND="
20         >=dev-python/requests-2.0[${PYTHON_USEDEP}]
21         dev-python/cookies[${PYTHON_USEDEP}]
22         dev-python/mock[${PYTHON_USEDEP}]
23         dev-python/six[${PYTHON_USEDEP}]
24 "
25
26 DEPEND="
27         dev-python/setuptools[${PYTHON_USEDEP}]
28         test? (
29                 ${RDEPEND}
30                 dev-python/pytest[${PYTHON_USEDEP}]
31                 dev-python/pytest-localserver[${PYTHON_USEDEP}]
32         )
33 "
34
35 python_test() {
36         py.test || die "tests failed with ${EPYTHON}"
37 }