dev-python/requests-toolbelt: keyworded 0.9.1 for ia64, bug #717946
[gentoo.git] / dev-python / requests-toolbelt / requests-toolbelt-0.9.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python{2_7,3_{6,7,8,9}} pypy3 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="A utility belt for advanced users of python-requests"
10 HOMEPAGE="https://toolbelt.readthedocs.org/"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
16 IUSE="test"
17
18 RDEPEND="<dev-python/requests-3.0.0[${PYTHON_USEDEP}]"
19 DEPEND="${RDEPEND}
20         test? (
21                 dev-python/betamax[${PYTHON_USEDEP}]
22                 dev-python/mock[${PYTHON_USEDEP}]
23         )"
24
25 DOCS=( AUTHORS.rst HISTORY.rst README.rst )
26
27 PATCHES=(
28         "${FILESDIR}/requests-toolbelt-0.8.0-test-tracebacks.patch"
29         "${FILESDIR}/requests-toolbelt-0.9.1-tests.patch"
30
31         # disable python2.7 test failures with newer requests versions
32         # bug: https://bugs.gentoo.org/635824
33         # https://github.com/requests/toolbelt/issues/213
34         "${FILESDIR}/requests-toolbelt-0.9.1-tests-py2.patch"
35
36         # disable tests that require internet access
37         "${FILESDIR}/requests-toolbelt-0.9.1-tests-internet.patch"
38 )
39
40 distutils_enable_tests pytest