*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / requests-ntlm / requests-ntlm-1.1.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_6 )
7
8 inherit distutils-r1
9
10 MY_PN="${PN/-/_}"
11
12 DESCRIPTION="HTTP NTLM authentication using the requests library"
13 HOMEPAGE="https://github.com/requests/requests-ntlm"
14 SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
15
16 SLOT="0"
17 LICENSE="ISC"
18 KEYWORDS="~amd64 ~x86"
19 IUSE=""
20
21 RDEPEND="
22         >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
23         >=dev-python/ntlm-auth-1.0.2[${PYTHON_USEDEP}]"
24
25 S=${WORKDIR}/${MY_PN}-${PV}