*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / requests-cache / requests-cache-0.4.12.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python2_7 python3_6 )
7
8 inherit distutils-r1
9
10 HOMEPAGE="https://pypi.org/project/requests-cache/"
11 DESCRIPTION="Persistent cache for requests library"
12 SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.zip"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="amd64 x86"
17 IUSE="doc"
18
19 # Portage only has versions of request >= minimum border
20 RDEPEND=">=dev-python/requests-2.6[${PYTHON_USEDEP}]"
21 DEPEND="
22         dev-python/setuptools[${PYTHON_USEDEP}]
23         doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
24
25 # Testsuite excels in tests connecting to the network via local server daemons
26 python_compile_all() {
27         use doc && emake -C docs html
28 }
29
30 python_install_all() {
31         use doc && local HTML_DOCS=( docs/_build/html/. )
32         distutils-r1_python_install_all
33 }