*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / rebulk / rebulk-0.9.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_6} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Python library that performs advanced searches in strings"
11 HOMEPAGE="https://github.com/Toilal/rebulk https://pypi.org/project/rebulk/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="MIT Apache-2.0"
15 SLOT="0"
16 KEYWORDS="amd64 x86"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
21 DEPEND="${RDEPEND}
22         dev-python/setuptools[${PYTHON_USEDEP}]
23         test? (
24                 dev-python/pytest[${PYTHON_USEDEP}]
25                 dev-python/pytest-runner[${PYTHON_USEDEP}]
26         )
27 "
28
29 python_prepare_all() {
30         # Remove base64-encoded zip archive with pytest.
31         rm runtests.py || die
32
33         # Disable unconditional dependency on dev-python/pytest-runner.
34         sed -i -e "s|'pytest-runner'||g" setup.py || die
35
36         distutils-r1_python_prepare_all
37 }
38
39 python_test() {
40         esetup.py test
41 }