f233087ee17bfbd965e204bca2cb95cf001c77a3
[gentoo.git] / dev-python / readme_renderer / readme_renderer-26.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DISTUTILS_USE_SETUPTOOLS=rdepend
7 PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
8
9 inherit distutils-r1
10
11 DESCRIPTION="a library for rendering \"readme\" descriptions for Warehouse"
12 HOMEPAGE="https://github.com/pypa/readme_renderer https://pypi.org/project/readme_renderer/"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
14
15 LICENSE="Apache-2.0"
16 SLOT="0"
17 KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ppc64 ~sparc ~x86"
18
19 RDEPEND="
20         >=dev-python/bleach-2.1.0[${PYTHON_USEDEP}]
21         >=dev-python/docutils-0.13.1[${PYTHON_USEDEP}]
22         >=dev-python/pygments-2.5.2[${PYTHON_USEDEP}]
23         dev-python/six[${PYTHON_USEDEP}]
24 "
25 BDEPEND="
26         test? ( dev-python/mock[${PYTHON_USEDEP}] )
27 "
28
29 DOCS=( README.rst )
30
31 distutils_enable_tests pytest