*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / ratelimit / ratelimit-1.4.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python3_6 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="An API rate limit decorator for Python"
10 SRC_URI="https://github.com/tomasbasham/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11 HOMEPAGE="https://github.com/tomasbasham/ratelimit"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="test"
17 RESTRICT="!test? ( test )"
18
19 DEPEND="
20         test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
21
22 src_prepare() {
23         default
24         # remove --cov args injection
25         rm pytest.ini || die
26 }
27
28 python_test() {
29         pytest || die
30 }