*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / rackspace-monitoring / rackspace-monitoring-0.8.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 PYTHON_COMPAT=( python2_7 python3_6 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Client library for Rackspace Cloud Monitoring"
10 HOMEPAGE="https://github.com/racker/rackspace-monitoring"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="test"
17 RESTRICT="test"  # resrticted for bug 636106
18
19 TEST_DEPENDS="dev-python/pep8[${PYTHON_USEDEP}]"
20 RDEPEND="
21         >=dev-python/libcloud-0.17.0[${PYTHON_USEDEP}]
22         <dev-python/libcloud-2.0[${PYTHON_USEDEP}]
23 "
24 DEPEND="
25         dev-python/setuptools[${PYTHON_USEDEP}]
26         test? (
27                 ${TEST_DEPENDS}
28                 ${RDEPEND}
29         )
30 "
31
32 python_test() {
33         ${EPYTHON} setup.py test || die
34 }