*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / qtawesome / qtawesome-0.5.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python{2_7,3_6,3_7} )
6 inherit eutils distutils-r1
7
8 DESCRIPTION="Enables iconic fonts such as Font Awesome in PyQt"
9 HOMEPAGE="https://github.com/spyder-ide/qtawesome/ https://pypi.org/project/QtAwesome/"
10 MY_PN="QtAwesome"
11 MY_P="${MY_PN}-${PV}"
12 SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 RDEPEND="media-fonts/fontawesome"
20 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
21
22 S="${WORKDIR}/${MY_P}"