*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / qrcode / qrcode-6.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="QR Code generator on top of PIL"
11 HOMEPAGE="https://pypi.org/project/qrcode/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="amd64 ~arm arm64 ~x86"
17
18 # optional deps:
19 # - pillow and lxml for svg backend, set as hard deps
20 RDEPEND="
21         dev-python/six[${PYTHON_USEDEP}]
22         dev-python/lxml[${PYTHON_USEDEP}]
23         dev-python/pillow[${PYTHON_USEDEP}]"
24 DEPEND="
25         dev-python/setuptools[${PYTHON_USEDEP}]
26         test? ( $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2) )"
27
28 distutils_enable_tests unittest
29
30 src_install() {
31         distutils-r1_src_install
32         doman doc/qr.1
33 }