*/*: [QA] Fix trivial cases of MissingTestRestrict
[gentoo.git] / dev-python / pyxdg / pyxdg-0.26-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7,3_8} pypy )
7 inherit distutils-r1
8
9 MY_P=${PN}-rel-${PV}
10 DESCRIPTION="A Python module to deal with freedesktop.org specifications"
11 HOMEPAGE="https://freedesktop.org/wiki/Software/pyxdg https://cgit.freedesktop.org/xdg/pyxdg/"
12 # official mirror of the git repo
13 SRC_URI="https://github.com/takluyver/pyxdg/archive/rel-${PV}.tar.gz -> ${MY_P}.tar.gz"
14
15 LICENSE="LGPL-2"
16 SLOT="0"
17 KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
18 IUSE="test"
19 RESTRICT="!test? ( test )"
20
21 DEPEND="
22         test? (
23                 dev-python/nose[${PYTHON_USEDEP}]
24                 x11-themes/hicolor-icon-theme
25         )"
26
27 S=${WORKDIR}/${MY_P}
28
29 python_test() {
30         nosetests -v || die
31 }