*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / pytools / pytools-2017.4-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_6} )
7 PYTHON_REQ_USE='sqlite'
8
9 inherit distutils-r1
10
11 DESCRIPTION="Collection of tools missing from the Python standard library"
12 HOMEPAGE="https://mathema.tician.de/software/pytools/"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
14
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
18 IUSE="test"
19 RESTRICT="!test? ( test )"
20
21 RDEPEND="
22         >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
23         >=dev-python/decorator-3.2.0[${PYTHON_USEDEP}]
24         >=dev-python/numpy-1.6.0[${PYTHON_USEDEP}]
25         >=dev-python/six-1.8.0[${PYTHON_USEDEP}]
26 "
27 DEPEND="
28         >=dev-python/setuptools-0.7.2[${PYTHON_USEDEP}]
29         test? (
30                 ${RDEPEND}
31                 dev-python/pytest[${PYTHON_USEDEP}]
32                 dev-python/pytest-runner[${PYTHON_USEDEP}]
33         )
34 "
35
36 python_test() {
37         py.test -v || die "Tests fail with ${EPYTHON}"
38 }